Debian 9 Stretch: Codecs multimedia en el repositorio oficial, el repositorio deb-multimedia, y Flash Player y algunas alternativas.


El repositorio deb-multimedia tradicionalmente se añade a las fuentes de software de Debian y, por lo general y aún siendo un repositorio de terceros, no suele generar problemas; al menos yo no los he tenido. Pero también es cierto, que es posible que no lo necesitemos, o sólo parcialmente. En cualquier caso, creo que lo importante es conocer las opciones que tenemos a este respecto.

Muchos codecs multimedia ya están en el repositorio oficial de Debian, como, por ejemplo MP3, H264 y codificación y decodificación AAC, que están disponible mediante las librerías ffmpeg que soportan desde los formatos más antiguos hasta los más novedosos. Los reproductores multimedia (VLC, Mplayer, por ejemplo) disponibles en el repositorio oficial utilizan estas bibliotecas, proporcionando soporte para la reproducción de archivos codificados a través de muchos codecs diferentes.

Al instalar un reproductor multimedia se instalarán automáticamente muchos codecs diferentes, que por lo general pueden satisfacer las necesidades de cualquier usuario. No obstante, es posible que algunos codecs que se necesiten no estén disponibles en el reproductor, por lo que se tienen que instalar algunos paquetes adicionales, que puede estar disponible en los repositorios de Debian o en el repositorio deb-multimedia.org

1. Repositorio deb-multimedia: añadirlo a las fuentes de software ¿O no?

Debian al igual que otras muchas distribuciones GNU/Linux, como puede ser openSUSE, sólo garantiza la estabilidad del sistema con los repositorios oficiales. El repositorio deb-multimedia no es oficial, aunque, sin duda, es fiable y los usuarios de Debian lo suelen instalar con toda tranquilidad; yo también. Ahora bien, también es cierto que es posible que no lo necesitemos en ningún caso, o sólo para algunas cuestiones puntuales.

Desde este repositorio podremos instalar, o actualizar, aplicaciones multimedia con versiones más actuales que la del repositorio oficial -como vlc, audacious, handbrake, kdenlive, etc- y codecs de audio y vídeo disponibles en Debian, pero también algunos no disponibles en Debian y que podamos necesitar de su sección “non-free” (flashplayer-mozilla, flashplayer-chromium, w64codecs o, en su caso, w32codecs), aunque con los disponibles en el repositorio oficial se cubren la mayor parte de los requerimientos (ver apartado siguiente). Así que es muy posible que no lo necesitemos. Lo que podemos hacer es añadirlo a nuestras fuentes de software y activarlo (marcarlo o desmascarlo en Synaptic) sólo cuando lo necesitemos: actualizar alguna aplicación o instalar algún codec multimedia concreto. O lo mantenemos activo para que los paquetes correspondientes se actualicen o se instalen desde este repositorio Multimedia. Como cada uno crea más conveniente.

1.1. Añadir Multimedia a nuestras fuentes de software

Para añadir el repositorio Multimedia, en la ventana “Repositorios” de Synaptic picamos en “Nuevo” y en los cajetines escribimos:

URI: http://www.deb-multimedia.org
Distribución: stretch
Sección(es): main non-free


Picamos en “Aceptar”, se recargan los repositorios y nos mandará un error pero que vamos a darle solución seguidamente, tras “Cerrar la ventana del mensaje”. En la ventana principal de Synaptic picamos en buscar para localizar el paquete deb-multimedia-keyring, botón derecho y seleccionamos “Marcar para instalar” y picamos en “Aplicar”.

Si este paquete no lo encontráramos aquí lo podemos descargar desde la página oficial www.deb-multimedia.org ⇒

Abrimos terminal en el explorador de archivos (F4 en KDE Plasma 5) en la carpeta donde se encuentre el paquete descargado y como superusuario ejecutamos:

# dpkg -i deb-multimedia-keyring_2016.8.1_all.deb

Ten en cuenta que el número de la versión puede cambiar con el tiempo, escribe la correcta.

1.2. Actualizar e instalar paquetes desde deb-multimedia ¿O no?

Si actualizamos el sistema (apt update & apt upgrade) con el repositorio deb-multimedia activo se actualizarán todos los paquetes desde este, tanto de aplicaciones como de codecs, y si instalamos un paquete que este en los dos repositorios (oficial de Debian y Multimedia) se instalará el que tenga la versión más actual; en principio desde Multimedia. Como decía antes lo podemos desactivar y sólo activarlo para instalar o actualizar algún paquete en concreto; para cualquiera de estas dos acciones utilizamos el comando:

# apt install nombre_paquete

2. Codecs multimedia

2.1. Codecs disponibles en el repositorio oficial

Algunos de los paquetes que aquí se sugieren para instalar pueden estar ya instalados, ya que depende del escritorio y de los reproductores multimedia ya instalados, o se instalarían al instalar un reproductor en concreto. En cualquier caso, personalmente prefiero instalarlos desde el principio para en cierto modo olvidarme de este asunto. Con el repositorio deb-multimedia desactivado para que los paquetes se instalen desde Debian, si es el caso, y como superusuario:

# su (contraseña)
# apt install ffmpeg libavcodec-extra gstreamer1.0-fluendo-mp3 gstreamer1.0-plugins-ugly gstreamer1.0-plugins-bad gstreamer1.0-pulseaudio vorbis-tools

2.2. Paquetes extra en deb-multimedia

Hay un paquete adicional que proporciona soporte para algunos codecs que raramente son utilizados y las únicas aplicaciones que al parecer hacen uso de ellos son Xine y Mplayer. Así que si utilizamos estos reproductores puede que necesitemos instalarlo. Con el repositorio deb-multimedia activado:

En los equipos amd64

# apt install w64codecs

Y en los equipos i386

# apt install w32codecs

3. Soporte para DVDs encriptados

Los DVDs suelen estar encriptados con CSS (Content Scramble System), y todos los reproductores multimedia tienen que utilizar libdvdcss2 para reproducirlos. Este paquete está disponible en el repositorio deb-multimedia. También se requiere para acceder a muchos DVDs la instalación del paquete libdvdread4. Este se encuentra también en el repositorio oficial y suele estar ya instalado en cuanto que por defecto puede que tengamos un reproductor que lee DVDs. Sea como sea tenemos dos opciones que pasan por el repositorio oficial de Debian o por deb-multimedia, según se prefiera:

3.1. Repositorio deb-multimedia: con este repositorio activo:

# apt install libdvdcss2 libdvdread4

3.2. Repositorio oficial:
en el repositorio oficial (sección contrib), se encuentra el paquete libdvd-pkg que proporciona las bibliotecas necesarias para reproducir con un reproductor multimedia (como VLC, SMPlayer, Totem, etc) vídeos DVDs. En realidad el paquete automatiza el proceso de descargar archivos de origen, compilar e instalar los paquetes binarios, incluido libdvdcss2.

# apt install libdvd-pkg

Durante la instalación surge un mensaje en relación a libdvdss2, que en definitiva nos indica que cuando termine la instalación ejecutemos un comando, picamos en “Aceptar” y Sí y Sí. El comando es el siguiente:

# dpkg-reconfigure libdvd-pkg

Nota: En realidad, prácticamente nunca veo DVDs en el ordenador, pero en esta ocasión para comprobar la primera opción los reproductores que no me han dado problemas, al menos con DVDs muy antiguos que son los que tengo, son Gxine y Mplayer (paquetes smplayer y mplayer); por si es de interés.

4. Flashplayer ¿Instalarlo o no instalarlo? Está es la cuestión

Flash es un riesgo de seguridad, no es una tecnología eficiente y hoy día prácticamente nadie usa Flash ... Esto es algo que me quedo claro, y con toda nitidez, tras leer un articulo en geekland que recomiendo si el tema no lo conocen: https:/geekland.eu/


Ahora bien, en algunos sitios Web se sigue utilizando esta tecnología y es posible que lo necesitemos. Tenemos varias opciones:

1. No instalamos Flashplayer y si encontráramos que lo necesitamos, entonces tenemos al menos las opciones 2 y 3.

2. En el repositorio de Debian disponemos de una alternativa, concretamente GNU Gnash, que puede funcionar en muchas aplicaciones Flash, pero en otras no. Así que si no detectamos deficiencias podemos utilizar la aplicación de código abierto. Además, también está disponible un plug-in para Firefox y derivados. Para instalar Gnash:

# apt install gnash

Para intalar el plug-in en Firefox, si es el navegador que utilizamos:

# apt install browser-plugin-gnash

Para comprobar que está instalado el plug-in teclear en la barra de direcciones de Firefox “about:addons”

3. Si todo eso no nos convence, o no nos funciona del todo y lo necesitamos, otra opción es instalar Flashplayer, y Flashblock que es una extensión de Firefox que nos permite decidir en cada momento que contenido reproducir y cual no.

# apt install flashplayer-mozilla xul-ext-flashblock

Por el momento voy a seguir la opción 1, después ya veremos; aunque, si me es necesario, comenzaré por la opción 2, y si sigue siendo necesario la opción 3; ya saben, por seguir un orden.

Saludos flamencos,
Fotografía de Aves y otros Seres Vivos ⇒


Comentarios